5412 C# Programming Manual: C:/C#/JY5412DIChangeDetectionTask.cs File Reference

5412 C# Programming Manual
5412C# Programming Manual
  • Main Page
  • Packages
  • Classes
  • Files
  • File List
  • C:
  • C#
Classes | Namespaces | Enumerations
JY5412DIChangeDetectionTask.cs File Reference

Classes

class | JY5412.JY5412DIChangeDetectionTask
JY5412 DIChange Detection Task. More...
class | JY5412.ChangeDetectionChannel
ChangeDetectionChannel class. More...
class | JY5412.ChangeDetectionEventChannel
ChangeDetectionEventChannel class. More...

Namespaces

namespace JY5412

Enumerations

enum JY5412.ChangeDetectionMode { JY5412.RisingEdge = JY5412Import.RisingEdge , JY5412.FallingEdge = JY5412Import.FallingEdge , JY5412.BothEdge = JY5412Import.BothEdge }
ChangeDetectionMode. More...
Generated by doxygen 1.15.0


5412 C# Programming Manual: C:/C#/JY5412DITask.cs File Reference

  • Packages
  • Classes
  • Files
  • File List
  • C:
  • C#
Classes | Namespaces | Enumerations
JY5412DITask.cs File Reference

Classes

class | JY5412.JY5412DITask
DITask class. More...
class | JY5412.DIChannel
DIChannel class. More...

Namespaces

namespace JY5412

Enumerations

enum JY5412.DITerminal { JY5412.Floating = JY5412Import.Floating , JY5412.PullUp = JY5412Import.PullUp , JY5412.PullDown = JY5412Import.PullDown }
Input terminal. More...


5412 C# Programming Manual: C:/C#/JY5412DOTask.cs File Reference

  • File List
  • C:
  • C#
Classes | Namespaces | Enumerations
JY5412DOTask.cs File Reference

Classes

class | JY5412.JY5412DOTask
DOTask class. More...
class | JY5412.DOChannel
DOChannel class. More...

Namespaces

namespace JY5412

Enumerations

enum JY5412.DOTerminal { JY5412.PushPull = JY5412Import.PushPull , JY5412.OpenDrain = JY5412Import.OpenDrain }
DO terminal. More...


5412 C# Programming Manual: C:/C#/JY5412DOWatchdogTask.cs File Reference

  • File List
  • C:
  • C#
Classes | Namespaces | Enumerations
JY5412DOWatchdogTask.cs File Reference

Classes

class | JY5412.JY5412DOWatchdogTask
DO Watchdog Task. More...
class | JY5412.WatchdogChannel
WatchdogChannel class. More...

Namespaces

namespace JY5412

Enumerations

enum JY5412.WatchdogExpirationState { JY5412.High = JY5412Import.High , JY5412.Low = JY5412Import.Low , JY5412.Tristate = JY5412Import.Tristate , JY5412.NoChange = JY5412Import.NoChange }
Watchdog expiration state. More...


5412 C# Programming Manual: C:/C#/JY5412PowerUpStates.cs File Reference

  • File List
  • C:
  • C#
Classes | Namespaces | Enumerations
JY5412PowerUpStates.cs File Reference

Classes

class | JY5412.JY5412PowerUpStates
Power-on state configuration. More...
class | JY5412.PowerUpStatePortParam
The class used to set the default logic level of the power-on state. More...
class | JY5412.ChannelPowerUpStates
A class for setting the default power-on state of input or output. More...
class | JY5412.PowerUpStateInputParam
Input PowerUpStates param. More...
class | JY5412.PowerUpStateOutputParam
Output PowerUpStates param. More...

Namespaces

namespace JY5412

Enumerations

enum JY5412.PowerUpStateMode { JY5412.Output , JY5412.Input }
Power Up State Mode. More...


5412 C# Programming Manual: Class List

  • Class List
  • Class Index
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
N JY5412 |
C JY5412DIChangeDetectionTask | JY5412 DIChange Detection Task
C ChangeDetectionChannel | ChangeDetectionChannel class
C ChangeDetectionEventChannel | ChangeDetectionEventChannel class
C JY5412DITask | DITask class
C DIChannel | DIChannel class
C JY5412DOTask | DOTask class
C DOChannel | DOChannel class
C JY5412DOWatchdogTask | DO Watchdog Task
C WatchdogChannel | WatchdogChannel class
C JY5412PowerUpStates | Power-on state configuration
C PowerUpStatePortParam | The class used to set the default logic level of the power-on state
C ChannelPowerUpStates | A class for setting the default power-on state of input or output
C PowerUpStateInputParam | Input PowerUpStates param
C PowerUpStateOutputParam | Output PowerUpStates param


5412 C# Programming Manual: JY5412.ChangeDetectionChannel Class Reference

  • JY5412
  • ChangeDetectionChannel
Properties | List of all members
JY5412.ChangeDetectionChannel Class Referencesealed

ChangeDetectionChannel class. More...

Properties

int | PortID [get, set]
PortID.
int | LineID [get, set]
LineID.
ChangeDetectionMode | ChangeDetectionMode [get, set]
Change detection mode.
DITerminal | Terminal [get, set]
DI Terminal.
bool | EnableDigitalFilter [get, set]
Enable digital filter.

Detailed Description

ChangeDetectionChannel class.

Property Documentation

◆ ChangeDetectionMode

ChangeDetectionMode JY5412.ChangeDetectionChannel.ChangeDetectionMode
getset

Change detection mode.

◆ EnableDigitalFilter

bool JY5412.ChangeDetectionChannel.EnableDigitalFilter
getset

Enable digital filter.

◆ LineID

int JY5412.ChangeDetectionChannel.LineID
getset

LineID.

◆ PortID

int JY5412.ChangeDetectionChannel.PortID
getset

PortID.

◆ Terminal

DITerminal JY5412.ChangeDetectionChannel.Terminal
getset

DI Terminal.

The documentation for this class was generated from the following file:
  • C:/C#/JY5412DIChangeDetectionTask.cs


5412 C# Programming Manual: Member List

  • ChangeDetectionChannel
JY5412.ChangeDetectionChannel Member List

This is the complete list of members for JY5412.ChangeDetectionChannel, including all inherited members.

ChangeDetectionMode | JY5412.ChangeDetectionChannel
EnableDigitalFilter | JY5412.ChangeDetectionChannel
LineID | JY5412.ChangeDetectionChannel
PortID | JY5412.ChangeDetectionChannel
Terminal | JY5412.ChangeDetectionChannel


5412 C# Programming Manual: JY5412.ChangeDetectionEventChannel Class Reference

  • ChangeDetectionEventChannel
Properties | List of all members
JY5412.ChangeDetectionEventChannel Class Referencesealed

ChangeDetectionEventChannel class. More...

Properties

int | PortID [get, set]
PortID.
int | LineID [get, set]
LineID.
bool | Level [get, set]
The level that triggers the interruption can only be checked after the interruption occurs.

Detailed Description

ChangeDetectionEventChannel class.

Property Documentation

◆ Level

bool JY5412.ChangeDetectionEventChannel.Level
getset

The level that triggers the interruption can only be checked after the interruption occurs.

◆ LineID

int JY5412.ChangeDetectionEventChannel.LineID
getset

LineID.

◆ PortID

int JY5412.ChangeDetectionEventChannel.PortID
getset

PortID.

The documentation for this class was generated from the following file:
  • C:/C#/JY5412DIChangeDetectionTask.cs


5412 C# Programming Manual: Member List

  • ChangeDetectionEventChannel
JY5412.ChangeDetectionEventChannel Member List

This is the complete list of members for JY5412.ChangeDetectionEventChannel, including all inherited members.

Level | JY5412.ChangeDetectionEventChannel
LineID | JY5412.ChangeDetectionEventChannel
PortID | JY5412.ChangeDetectionEventChannel


5412 C# Programming Manual: JY5412.ChannelPowerUpStates Class Reference

  • ChannelPowerUpStates
Properties | List of all members
JY5412.ChannelPowerUpStates Class Referencesealed

A class for setting the default power-on state of input or output. More...

Properties

PowerUpStateMode | Mode [get, set]
Set PowerUpStates as input or output.
PowerUpStateInputParam | Input [get, set]
Input PowerUpStates.
PowerUpStateOutputParam | Output [get, set]
OutPut PowerUpStates.

Detailed Description

A class for setting the default power-on state of input or output.

Property Documentation

◆ Input

PowerUpStateInputParam JY5412.ChannelPowerUpStates.Input
getset

Input PowerUpStates.

◆ Mode

PowerUpStateMode JY5412.ChannelPowerUpStates.Mode
getset

Set PowerUpStates as input or output.

The default setting is output.

◆ Output

PowerUpStateOutputParam JY5412.ChannelPowerUpStates.Output
getset

OutPut PowerUpStates.

The documentation for this class was generated from the following file:
  • C:/C#/JY5412PowerUpStates.cs


5412 C# Programming Manual: Member List

  • ChannelPowerUpStates
JY5412.ChannelPowerUpStates Member List

This is the complete list of members for JY5412.ChannelPowerUpStates, including all inherited members.

Input | JY5412.ChannelPowerUpStates
Mode | JY5412.ChannelPowerUpStates
Output | JY5412.ChannelPowerUpStates


5412 C# Programming Manual: JY5412.DIChannel Class Reference

  • DIChannel
Properties | List of all members
JY5412.DIChannel Class Referencesealed

DIChannel class. More...

Properties

int | PortID [get, set]
PortID.
int | LineID [get, set]
LineID.
DITerminal | Terminal [get, set]
DI terminal.
bool | EnableDigitalFilter [get, set]
Enable digital filter.

Detailed Description

DIChannel class.

Property Documentation

◆ EnableDigitalFilter

bool JY5412.DIChannel.EnableDigitalFilter
getset

Enable digital filter.

◆ LineID

int JY5412.DIChannel.LineID
getset

LineID.

◆ PortID

int JY5412.DIChannel.PortID
getset

PortID.

◆ Terminal

DITerminal JY5412.DIChannel.Terminal
getset

DI terminal.

The documentation for this class was generated from the following file:
  • C:/C#/JY5412DITask.cs


5412 C# Programming Manual: Member List

  • DIChannel
JY5412.DIChannel Member List

This is the complete list of members for JY5412.DIChannel, including all inherited members.

EnableDigitalFilter | JY5412.DIChannel
LineID | JY5412.DIChannel
PortID | JY5412.DIChannel
Terminal | JY5412.DIChannel


5412 C# Programming Manual: JY5412.DOChannel Class Reference

  • DOChannel
Properties | List of all members
JY5412.DOChannel Class Referencesealed

DOChannel class. More...

Properties

int | PortID [get, set]
PortID.
int | LineID [get, set]
LineID.
DOTerminal | Terminal [get, set]
DO terminal.

Detailed Description

DOChannel class.

Property Documentation

◆ LineID

int JY5412.DOChannel.LineID
getset

LineID.

◆ PortID

int JY5412.DOChannel.PortID
getset

PortID.

◆ Terminal

DOTerminal JY5412.DOChannel.Terminal
getset

DO terminal.

The documentation for this class was generated from the following file:
  • C:/C#/JY5412DOTask.cs


5412 C# Programming Manual: Member List

  • DOChannel
JY5412.DOChannel Member List

This is the complete list of members for JY5412.DOChannel, including all inherited members.

LineID | JY5412.DOChannel
PortID | JY5412.DOChannel
Terminal | JY5412.DOChannel


5412 C# Programming Manual: JY5412.JY5412DIChangeDetectionTask Class Reference

  • JY5412DIChangeDetectionTask
Public Member Functions | Properties | Events | List of all members
JY5412.JY5412DIChangeDetectionTask Class Reference

JY5412 DIChange Detection Task. More...

Public Member Functions

JY5412DIChangeDetectionTask (int slotNumber=0)
Inite JY5412DOWatchdogTask.
JY5412DIChangeDetectionTask (string boardName)
Inite JY5412DOWatchdogTask.
void | Start ()
start
void | Stop ()
Stop.
void | AddChannel (int portID, int lineID, ChangeDetectionMode changeDetectionMode, DITerminal terminal, bool enableDigitalFilter=false)
add single channel
void | AddChannel (int portID, int[] lineID, ChangeDetectionMode changeDetectionMode, DITerminal terminal, bool enableDigitalFilter=false)
Add multiple channels.
void | AddChannel (int portID, int[] lineID, ChangeDetectionMode[] changeDetectionMode, DITerminal terminal, bool enableDigitalFilter=false)
Add multiple channels.
void | AddChannel (int portID, int[] lineID, ChangeDetectionMode changeDetectionMode, DITerminal[] terminal, bool enableDigitalFilter=false)
Add multiple channels.
void | AddChannel (int portID, int[] lineID, ChangeDetectionMode[] changeDetectionMode, DITerminal[] terminal, bool enableDigitalFilter=false)
Add multiple channels.
void | AddChannel (int[] portID, int[] lineID, ChangeDetectionMode[] changeDetectionMode, DITerminal[] terminal, bool enableDigitalFilter=false)
Add multiple channels.
void | AddChannel (int[] portID, int[] lineID, ChangeDetectionMode[] changeDetectionMode, DITerminal[] terminal, bool[] enableDigitalFilter)
Add multiple channels.
void | AddChannel (int[] portID, int[] lineID, ChangeDetectionMode changeDetectionMode, DITerminal terminal, bool enableDigitalFilter=false)
Add multiple channels.
void | RemoveChannel (int portID, int lineID)
Delete the specified line number .If it is -1, delete all lines.
void | RemoveChannel (int[] portID, int[] lineID)
Delete the specified line number .
void | ReadSinglePoint (ref bool[] readValues)
Read one sample to all lines in register .
void | ReadSinglePoint (ref bool readValue, int portID, int lineID)
Read one sample to the specified line in register.

Properties

List< ChangeDetectionChannel > | Channels [get, set]
ChangeDetectionChannel list.
JY5412Device | Device [get]
JY5412Device.

Events

ChangeDetectionEventHandler ChangeDetected [add, remove]
Change detection event.

Detailed Description

JY5412 DIChange Detection Task.

Constructor & Destructor Documentation

◆ JY5412DIChangeDetectionTask() [1/2]

JY5412.JY5412DIChangeDetectionTask.JY5412DIChangeDetectionTask ( int slotNumber = 0 )

Inite JY5412DOWatchdogTask.

Parameters
slotNumber

◆ JY5412DIChangeDetectionTask() [2/2]

JY5412.JY5412DIChangeDetectionTask.JY5412DIChangeDetectionTask ( string boardName )

Inite JY5412DOWatchdogTask.

Parameters
boardName

Member Function Documentation

◆ AddChannel() [1/8]

void JY5412.JY5412DIChangeDetectionTask.AddChannel | ( | int | portID,
 |  | int | lineID,
 |  | ChangeDetectionMode | changeDetectionMode,
 |  | DITerminal | terminal,
 |  | bool | enableDigitalFilter = false )

add single channel

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | lineID number to be added.If lineID is equal to -1, then add all the corresponding Line for the PortID.
changeDetectionMode | ChangeDetection mode.
terminal | terminal configuration.
enableDigitalFilter | Enable digital filtering.

◆ AddChannel() [2/8]

void JY5412.JY5412DIChangeDetectionTask.AddChannel | ( | int | portID,
 |  | int[] | lineID,
 |  | ChangeDetectionMode | changeDetectionMode,
 |  | DITerminal | terminal,
 |  | bool | enableDigitalFilter = false )

Add multiple channels.

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | an array of line numbers of added lines.
changeDetectionMode | ChangeDetection mode.
terminal | terminal configuration.
enableDigitalFilter | Enable digital filtering.

◆ AddChannel() [3/8]

void JY5412.JY5412DIChangeDetectionTask.AddChannel | ( | int | portID,
 |  | int[] | lineID,
 |  | ChangeDetectionMode | changeDetectionMode,
 |  | DITerminal[] | terminal,
 |  | bool | enableDigitalFilter = false )

Add multiple channels.

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | an array of line numbers of added lines.
changeDetectionMode | ChangeDetection mode.
terminal | an array of Input mode.
enableDigitalFilter | Enable digital filtering.

◆ AddChannel() [4/8]

void JY5412.JY5412DIChangeDetectionTask.AddChannel | ( | int | portID,
 |  | int[] | lineID,
 |  | ChangeDetectionMode[] | changeDetectionMode,
 |  | DITerminal | terminal,
 |  | bool | enableDigitalFilter = false )

Add multiple channels.

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | an array of line numbers of added lines.
changeDetectionMode | an array of ChangeDetection mode.
terminal | terminal configuration.
enableDigitalFilter | Enable digital filtering.

◆ AddChannel() [5/8]

void JY5412.JY5412DIChangeDetectionTask.AddChannel | ( | int | portID,
 |  | int[] | lineID,
 |  | ChangeDetectionMode[] | changeDetectionMode,
 |  | DITerminal[] | terminal,
 |  | bool | enableDigitalFilter = false )

Add multiple channels.

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | an array of line numbers of added lines.
changeDetectionMode | an array of ChangeDetection mode.
terminal | an array of terminal configuration.
enableDigitalFilter | Enable digital filtering.

◆ AddChannel() [6/8]

void JY5412.JY5412DIChangeDetectionTask.AddChannel | ( | int[] | portID,
 |  | int[] | lineID,
 |  | ChangeDetectionMode | changeDetectionMode,
 |  | DITerminal | terminal,
 |  | bool | enableDigitalFilter = false )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | an array of line numbers of added lines.
terminal | terminal configuration.
enableDigitalFilter | Enable digital filtering.

◆ AddChannel() [7/8]

void JY5412.JY5412DIChangeDetectionTask.AddChannel | ( | int[] | portID,
 |  | int[] | lineID,
 |  | ChangeDetectionMode[] | changeDetectionMode,
 |  | DITerminal[] | terminal,
 |  | bool | enableDigitalFilter = false )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | an array of line numbers of added lines.
changeDetectionMode
terminal | an array of terminal configuration.
enableDigitalFilter | Enable digital filtering.

◆ AddChannel() [8/8]

void JY5412.JY5412DIChangeDetectionTask.AddChannel | ( | int[] | portID,
 |  | int[] | lineID,
 |  | ChangeDetectionMode[] | changeDetectionMode,
 |  | DITerminal[] | terminal,
 |  | bool[] | enableDigitalFilter )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | an array of line numbers of added lines.
changeDetectionMode
terminal | an array of terminal configuration.
enableDigitalFilter | an array of enable digital filtering.

◆ ReadSinglePoint() [1/2]

void JY5412.JY5412DIChangeDetectionTask.ReadSinglePoint | ( | ref bool | readValue,
 |  | int | portID,
 |  | int | lineID )

Read one sample to the specified line in register.

/>

Parameters
readValue | Read value.
portID | port ID.
lineID | Specified line.

◆ ReadSinglePoint() [2/2]

void JY5412.JY5412DIChangeDetectionTask.ReadSinglePoint ( ref bool[] readValues )

Read one sample to all lines in register .

/>

Parameters
readValues Read Values.Buffer size >= number of lines。

◆ RemoveChannel() [1/2]

void JY5412.JY5412DIChangeDetectionTask.RemoveChannel | ( | int | portID,
 |  | int | lineID )

Delete the specified line number .If it is -1, delete all lines.

Parameters
portID | port number to be delete.
lineID | line number to be delete.

◆ RemoveChannel() [2/2]

void JY5412.JY5412DIChangeDetectionTask.RemoveChannel | ( | int[] | portID,
 |  | int[] | lineID )

Delete the specified line number .

Parameters
portID | port number to be delete.
lineID | line number to be delete.

◆ Start()

void JY5412.JY5412DIChangeDetectionTask.Start ( )

start

Exceptions
JYDriverException

◆ Stop()

void JY5412.JY5412DIChangeDetectionTask.Stop ( )

Stop.

Exceptions
JYDriverException

Property Documentation

◆ Channels

List<ChangeDetectionChannel> JY5412.JY5412DIChangeDetectionTask.Channels
getset

ChangeDetectionChannel list.

◆ Device

JY5412Device JY5412.JY5412DIChangeDetectionTask.Device
get

JY5412Device.

Event Documentation

◆ ChangeDetected

ChangeDetectionEventHandler JY5412.JY5412DIChangeDetectionTask.ChangeDetected
addremove

Change detection event.

The documentation for this class was generated from the following file:
  • C:/C#/JY5412DIChangeDetectionTask.cs


5412 C# Programming Manual: Member List

  • JY5412DIChangeDetectionTask
JY5412.JY5412DIChangeDetectionTask Member List

This is the complete list of members for JY5412.JY5412DIChangeDetectionTask, including all inherited members.

AddChannel(int portID, int lineID, ChangeDetectionMode changeDetectionMode, DITerminal terminal, bool enableDigitalFilter=false) | JY5412.JY5412DIChangeDetectionTask
AddChannel(int portID, int[] lineID, ChangeDetectionMode changeDetectionMode, DITerminal terminal, bool enableDigitalFilter=false) | JY5412.JY5412DIChangeDetectionTask
AddChannel(int portID, int[] lineID, ChangeDetectionMode[] changeDetectionMode, DITerminal terminal, bool enableDigitalFilter=false) | JY5412.JY5412DIChangeDetectionTask
AddChannel(int portID, int[] lineID, ChangeDetectionMode changeDetectionMode, DITerminal[] terminal, bool enableDigitalFilter=false) | JY5412.JY5412DIChangeDetectionTask
AddChannel(int portID, int[] lineID, ChangeDetectionMode[] changeDetectionMode, DITerminal[] terminal, bool enableDigitalFilter=false) | JY5412.JY5412DIChangeDetectionTask
AddChannel(int[] portID, int[] lineID, ChangeDetectionMode[] changeDetectionMode, DITerminal[] terminal, bool enableDigitalFilter=false) | JY5412.JY5412DIChangeDetectionTask
AddChannel(int[] portID, int[] lineID, ChangeDetectionMode[] changeDetectionMode, DITerminal[] terminal, bool[] enableDigitalFilter) | JY5412.JY5412DIChangeDetectionTask
AddChannel(int[] portID, int[] lineID, ChangeDetectionMode changeDetectionMode, DITerminal terminal, bool enableDigitalFilter=false) | JY5412.JY5412DIChangeDetectionTask
ChangeDetected | JY5412.JY5412DIChangeDetectionTask
Channels | JY5412.JY5412DIChangeDetectionTask
Device | JY5412.JY5412DIChangeDetectionTask
JY5412DIChangeDetectionTask(int slotNumber=0) | JY5412.JY5412DIChangeDetectionTask
JY5412DIChangeDetectionTask(string boardName) | JY5412.JY5412DIChangeDetectionTask
ReadSinglePoint(ref bool[] readValues) | JY5412.JY5412DIChangeDetectionTask
ReadSinglePoint(ref bool readValue, int portID, int lineID) | JY5412.JY5412DIChangeDetectionTask
RemoveChannel(int portID, int lineID) | JY5412.JY5412DIChangeDetectionTask
RemoveChannel(int[] portID, int[] lineID) | JY5412.JY5412DIChangeDetectionTask
Start() | JY5412.JY5412DIChangeDetectionTask
Stop() | JY5412.JY5412DIChangeDetectionTask


5412 C# Programming Manual: JY5412.JY5412DITask Class Reference

  • JY5412DITask
Public Member Functions | Properties | List of all members
JY5412.JY5412DITask Class Referencesealed

DITask class. More...

Public Member Functions

JY5412DITask (int slotNum)
JY5412DITask.
JY5412DITask (string boardName)
Constructor.
void | AddChannel (int portID, int lineID, DITerminal terminal, bool enableDigitalFilter=false)
add single channel
void | AddChannel (int portID, int[] lineID, DITerminal terminal, bool enableDigitalFilter=false)
Add multiple channels.
void | AddChannel (int portID, int[] lineID, DITerminal[] terminal, bool[] enableDigitalFilter)
Add multiple channels.
void | AddChannel (int portID, int[] lineID, DITerminal[] terminal)
Add multiple channels.
void | AddChannel (int[] portID, int[] lineID, DITerminal[] terminal, bool enableDigitalFilter=false)
Add multiple channels.
void | AddChannel (int[] portID, int[] lineID, DITerminal[] terminal, bool[] enableDigitalFilter)
Add multiple channels.
void | AddChannel (int[] portID, int[] lineID, DITerminal terminal, bool enableDigitalFilter=false)
Add multiple channels.
void | RemoveChannel (int portID, int lineID)
Delete the specified line number .If it is -1, delete all lines.
void | RemoveChannel (int[] portID, int[] lineID)
Delete the specified line number .
void | ReadSinglePoint (ref bool[] readValues)
Read one sample to all lines in register .
void | ReadSinglePoint (ref bool readValue, int portID, int lineID)
Read one sample to the specified line in register.

Properties

List< DIChannel > | Channels [get, set]
DIChannel list.
JY5412Device | Device [get]
JY5412Device.

Detailed Description

DITask class.

Constructor & Destructor Documentation

◆ JY5412DITask() [1/2]

JY5412.JY5412DITask.JY5412DITask ( int slotNum )

JY5412DITask.

Parameters
slotNum board slotNum

◆ JY5412DITask() [2/2]

JY5412.JY5412DITask.JY5412DITask ( string boardName )

Constructor.

Used to create an DITask object.

Parameters
boardName Card Name

Member Function Documentation

◆ AddChannel() [1/7]

void JY5412.JY5412DITask.AddChannel | ( | int | portID,
 |  | int | lineID,
 |  | DITerminal | terminal,
 |  | bool | enableDigitalFilter = false )

add single channel

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | lineID number to be added.If lineID is equal to -1, then add all the corresponding Line for the PortID.
terminal | terminal configuration.
enableDigitalFilter | Enable digital filtering.

◆ AddChannel() [2/7]

void JY5412.JY5412DITask.AddChannel | ( | int | portID,
 |  | int[] | lineID,
 |  | DITerminal | terminal,
 |  | bool | enableDigitalFilter = false )

Add multiple channels.

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | an array of line numbers of added lines.
terminal | terminal configuration.
enableDigitalFilter | Enable digital filtering.

◆ AddChannel() [3/7]

void JY5412.JY5412DITask.AddChannel | ( | int | portID,
 |  | int[] | lineID,
 |  | DITerminal[] | terminal )

Add multiple channels.

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | an array of line numbers of added lines.
terminal | an array of terminal configurations.

◆ AddChannel() [4/7]

void JY5412.JY5412DITask.AddChannel | ( | int | portID,
 |  | int[] | lineID,
 |  | DITerminal[] | terminal,
 |  | bool[] | enableDigitalFilter )

Add multiple channels.

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | an array of line numbers of added lines.
terminal | an array of terminal configurations.
enableDigitalFilter | an array of enable digital filtering.

◆ AddChannel() [5/7]

void JY5412.JY5412DITask.AddChannel | ( | int[] | portID,
 |  | int[] | lineID,
 |  | DITerminal | terminal,
 |  | bool | enableDigitalFilter = false )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | an array of line numbers of added lines.
terminal | output terminal.
enableDigitalFilter | Enable digital filtering.

◆ AddChannel() [6/7]

void JY5412.JY5412DITask.AddChannel | ( | int[] | portID,
 |  | int[] | lineID,
 |  | DITerminal[] | terminal,
 |  | bool | enableDigitalFilter = false )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | an array of line numbers of added lines.
terminal | an array of terminal configurations.
enableDigitalFilter | Enable digital filtering.

◆ AddChannel() [7/7]

void JY5412.JY5412DITask.AddChannel | ( | int[] | portID,
 |  | int[] | lineID,
 |  | DITerminal[] | terminal,
 |  | bool[] | enableDigitalFilter )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | an array of line numbers of added lines.
terminal | an array of terminal configurations.
enableDigitalFilter | an array of enable digital filtering.

◆ ReadSinglePoint() [1/2]

void JY5412.JY5412DITask.ReadSinglePoint | ( | ref bool | readValue,
 |  | int | portID,
 |  | int | lineID )

Read one sample to the specified line in register.

/>

Parameters
readValue | Read value.
portID | port ID.
lineID | Specified line.

◆ ReadSinglePoint() [2/2]

void JY5412.JY5412DITask.ReadSinglePoint ( ref bool[] readValues )

Read one sample to all lines in register .

/>

Parameters
readValues Read Values.Buffer size >= number of lines。

◆ RemoveChannel() [1/2]

void JY5412.JY5412DITask.RemoveChannel | ( | int | portID,
 |  | int | lineID )

Delete the specified line number .If it is -1, delete all lines.

Parameters
portID | port number to be delete.
lineID | line number to be delete.

◆ RemoveChannel() [2/2]

void JY5412.JY5412DITask.RemoveChannel | ( | int[] | portID,
 |  | int[] | lineID )

Delete the specified line number .

Parameters
portID | port number to be delete.
lineID | line number to be delete.

Property Documentation

◆ Channels

List<DIChannel> JY5412.JY5412DITask.Channels
getset

DIChannel list.

◆ Device

JY5412Device JY5412.JY5412DITask.Device
get

JY5412Device.

The documentation for this class was generated from the following file:
  • C:/C#/JY5412DITask.cs


5412 C# Programming Manual: Member List

  • JY5412DITask
JY5412.JY5412DITask Member List

This is the complete list of members for JY5412.JY5412DITask, including all inherited members.

AddChannel(int portID, int lineID, DITerminal terminal, bool enableDigitalFilter=false) | JY5412.JY5412DITask
AddChannel(int portID, int[] lineID, DITerminal terminal, bool enableDigitalFilter=false) | JY5412.JY5412DITask
AddChannel(int portID, int[] lineID, DITerminal[] terminal, bool[] enableDigitalFilter) | JY5412.JY5412DITask
AddChannel(int portID, int[] lineID, DITerminal[] terminal) | JY5412.JY5412DITask
AddChannel(int[] portID, int[] lineID, DITerminal[] terminal, bool enableDigitalFilter=false) | JY5412.JY5412DITask
AddChannel(int[] portID, int[] lineID, DITerminal[] terminal, bool[] enableDigitalFilter) | JY5412.JY5412DITask
AddChannel(int[] portID, int[] lineID, DITerminal terminal, bool enableDigitalFilter=false) | JY5412.JY5412DITask
Channels | JY5412.JY5412DITask
Device | JY5412.JY5412DITask
JY5412DITask(int slotNum) | JY5412.JY5412DITask
JY5412DITask(string boardName) | JY5412.JY5412DITask
ReadSinglePoint(ref bool[] readValues) | JY5412.JY5412DITask
ReadSinglePoint(ref bool readValue, int portID, int lineID) | JY5412.JY5412DITask
RemoveChannel(int portID, int lineID) | JY5412.JY5412DITask
RemoveChannel(int[] portID, int[] lineID) | JY5412.JY5412DITask


5412 C# Programming Manual: JY5412.JY5412DOTask Class Reference

  • JY5412DOTask
Public Member Functions | Properties | List of all members
JY5412.JY5412DOTask Class Referencesealed

DOTask class. More...

Public Member Functions

JY5412DOTask (int slotNum)
JY5412DOTask.
JY5412DOTask (string boardName)
Constructor.
void | AddChannel (int portID, int lineID, DOTerminal terminal)
add single channel
void | AddChannel (int portID, int[] lineID, DOTerminal terminal)
Add multiple channels.
void | AddChannel (int portID, int[] lineID, DOTerminal[] terminal)
Add multiple channels.
void | AddChannel (int[] portID, int[] lineID, DOTerminal[] terminal)
Add multiple channels.
void | AddChannel (int[] portID, int lineID, DOTerminal terminal)
Add multiple channels.
void | AddChannel (int[] portID, int lineID, DOTerminal[] terminal)
Add multiple channels.
void | AddChannel (int[] portID, int[] lineID, DOTerminal terminal)
Add multiple channels.
void | RemoveChannel (int portID, int lineID)
Delete the specified line number .If it is -1, delete all lines.
void | RemoveChannel (int[] portID, int[] lineID)
Delete the specified line number .
void | WriteSinglePoint (bool[] writeValues)
write one sample to all lines in register .
void | WriteSinglePoint (bool writeValue, int portID, int lineID)
Write one sample to the specified line in register />.

Properties

List< DOChannel > | Channels [get, set]
DOChannel list.
JY5412Device | Device [get]
JY5412Device.

Detailed Description

DOTask class.

Constructor & Destructor Documentation

◆ JY5412DOTask() [1/2]

JY5412.JY5412DOTask.JY5412DOTask ( int slotNum )

JY5412DOTask.

Parameters
slotNum board slotNum

◆ JY5412DOTask() [2/2]

JY5412.JY5412DOTask.JY5412DOTask ( string boardName )

Constructor.

Used to create an DOtask object.

Parameters
boardName Card Name.

Member Function Documentation

◆ AddChannel() [1/7]

void JY5412.JY5412DOTask.AddChannel | ( | int | portID,
 |  | int | lineID,
 |  | DOTerminal | terminal )

add single channel

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | lineID number to be added.If lineID is equal to -1, then add all the corresponding Line for the PortID.
terminal | terminal configuration.

◆ AddChannel() [2/7]

void JY5412.JY5412DOTask.AddChannel | ( | int | portID,
 |  | int[] | lineID,
 |  | DOTerminal | terminal )

Add multiple channels.

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | an array of line numbers of added lines.
terminal | terminal configuration.

◆ AddChannel() [3/7]

void JY5412.JY5412DOTask.AddChannel | ( | int | portID,
 |  | int[] | lineID,
 |  | DOTerminal[] | terminal )

Add multiple channels.

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | an array of line numbers of added lines.
terminal | an array of terminal configurations.

◆ AddChannel() [4/7]

void JY5412.JY5412DOTask.AddChannel | ( | int[] | portID,
 |  | int | lineID,
 |  | DOTerminal | terminal )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | lineID number to be added.If lineID is equal to -1, then add all the corresponding Line for the PortID.
terminal | terminal configuration.

◆ AddChannel() [5/7]

void JY5412.JY5412DOTask.AddChannel | ( | int[] | portID,
 |  | int | lineID,
 |  | DOTerminal[] | terminal )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | lineID number to be added.If lineID is equal to -1, then add all the corresponding Line for the PortID.
terminal | an array of terminal configurations.

◆ AddChannel() [6/7]

void JY5412.JY5412DOTask.AddChannel | ( | int[] | portID,
 |  | int[] | lineID,
 |  | DOTerminal | terminal )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | an array of line numbers of added lines.
terminal | terminal configuration.

◆ AddChannel() [7/7]

void JY5412.JY5412DOTask.AddChannel | ( | int[] | portID,
 |  | int[] | lineID,
 |  | DOTerminal[] | terminal )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | an array of line numbers of added lines.
terminal | an array of terminal configurations.

◆ RemoveChannel() [1/2]

void JY5412.JY5412DOTask.RemoveChannel | ( | int | portID,
 |  | int | lineID )

Delete the specified line number .If it is -1, delete all lines.

Parameters
portID | port number to be delete.
lineID | line number to be delete.

◆ RemoveChannel() [2/2]

void JY5412.JY5412DOTask.RemoveChannel | ( | int[] | portID,
 |  | int[] | lineID )

Delete the specified line number .

Parameters
portID | port number to be delete.
lineID | line number to be delete.

◆ WriteSinglePoint() [1/2]

void JY5412.JY5412DOTask.WriteSinglePoint | ( | bool | writeValue,
 |  | int | portID,
 |  | int | lineID )

Write one sample to the specified line in register />.

Parameters
writeValue | Write value.
portID | Specified port.
lineID | Specified line.

◆ WriteSinglePoint() [2/2]

void JY5412.JY5412DOTask.WriteSinglePoint ( bool[] writeValues )

write one sample to all lines in register .

" /> <param name="writeValues">write Values.Buffer size >= number of lines。

Property Documentation

◆ Channels

List<DOChannel> JY5412.JY5412DOTask.Channels
getset

DOChannel list.

◆ Device

JY5412Device JY5412.JY5412DOTask.Device
get

JY5412Device.

The documentation for this class was generated from the following file:
  • C:/C#/JY5412DOTask.cs


5412 C# Programming Manual: Member List

  • JY5412DOTask
JY5412.JY5412DOTask Member List

This is the complete list of members for JY5412.JY5412DOTask, including all inherited members.

AddChannel(int portID, int lineID, DOTerminal terminal) | JY5412.JY5412DOTask
AddChannel(int portID, int[] lineID, DOTerminal terminal) | JY5412.JY5412DOTask
AddChannel(int portID, int[] lineID, DOTerminal[] terminal) | JY5412.JY5412DOTask
AddChannel(int[] portID, int[] lineID, DOTerminal[] terminal) | JY5412.JY5412DOTask
AddChannel(int[] portID, int lineID, DOTerminal terminal) | JY5412.JY5412DOTask
AddChannel(int[] portID, int lineID, DOTerminal[] terminal) | JY5412.JY5412DOTask
AddChannel(int[] portID, int[] lineID, DOTerminal terminal) | JY5412.JY5412DOTask
Channels | JY5412.JY5412DOTask
Device | JY5412.JY5412DOTask
JY5412DOTask(int slotNum) | JY5412.JY5412DOTask
JY5412DOTask(string boardName) | JY5412.JY5412DOTask
RemoveChannel(int portID, int lineID) | JY5412.JY5412DOTask
RemoveChannel(int[] portID, int[] lineID) | JY5412.JY5412DOTask
WriteSinglePoint(bool[] writeValues) | JY5412.JY5412DOTask
WriteSinglePoint(bool writeValue, int portID, int lineID) | JY5412.JY5412DOTask


5412 C# Programming Manual: JY5412.JY5412DOWatchdogTask Class Reference

  • JY5412DOWatchdogTask
Public Member Functions | Properties | List of all members
JY5412.JY5412DOWatchdogTask Class Reference

DO Watchdog Task. More...

Public Member Functions

JY5412DOWatchdogTask (int slotNumber=0)
Inite JY5412DOWatchdogTask.
JY5412DOWatchdogTask (string boardName)
Inite JY5412DOWatchdogTask.
void | AddChannel (int portID, int lineID, WatchdogExpirationState expirationState)
add single channel
void | AddChannel (int portID, int[] lineID, WatchdogExpirationState expirationState)
Add multiple channels.
void | AddChannel (int portID, int[] lineID, WatchdogExpirationState[] expirationState)
Add multiple channels.
void | AddChannel (int[] portID, int[] lineID, WatchdogExpirationState[] expirationState)
Add multiple channels.
void | AddChannel (int[] portID, int[] lineID, WatchdogExpirationState expirationState)
Add multiple channels.
void | RemoveChannel (int portID, int lineID)
Delete the specified line number .If it is -1, delete all lines.
void | RemoveChannel (int[] portID, int[] lineID)
Delete the specified line number .
void | Start ()
启动看门狗任务 Run the watchdog task
void | Commit ()
After modifying the expiration status and timeout time during the operation, submit the configuration.
void | ClearExpiration ()
Clear the locked state of the timeout watchdog task.
void | ResetTimer ()
Resetting the watchdog task is equivalent to feeding the dog.
void | Stop ()
停止看门狗任务 Stop the watchdog task

Properties

List< WatchdogChannel > | Channels [get, set]
WatchdogChannel list.
double | Timeout [get, set]
Timeout time, unit: seconds.
bool | Expired [get]
Check to see if the watchdog has expired.
JY5412Device | Device [get]
JY5412Device.

Detailed Description

DO Watchdog Task.

Constructor & Destructor Documentation

◆ JY5412DOWatchdogTask() [1/2]

JY5412.JY5412DOWatchdogTask.JY5412DOWatchdogTask ( int slotNumber = 0 )

Inite JY5412DOWatchdogTask.

Parameters
slotNumber

◆ JY5412DOWatchdogTask() [2/2]

JY5412.JY5412DOWatchdogTask.JY5412DOWatchdogTask ( string boardName )

Inite JY5412DOWatchdogTask.

Parameters
boardName

Member Function Documentation

◆ AddChannel() [1/5]

void JY5412.JY5412DOWatchdogTask.AddChannel | ( | int | portID,
 |  | int | lineID,
 |  | WatchdogExpirationState | expirationState )

add single channel

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | lineID number to be added.If lineID is equal to -1, then add all the corresponding Line for the PortID.
expirationState | Expiration state.

◆ AddChannel() [2/5]

void JY5412.JY5412DOWatchdogTask.AddChannel | ( | int | portID,
 |  | int[] | lineID,
 |  | WatchdogExpirationState | expirationState )

Add multiple channels.

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | an array of line numbers of added lines.
expirationState | Expiration state.

◆ AddChannel() [3/5]

void JY5412.JY5412DOWatchdogTask.AddChannel | ( | int | portID,
 |  | int[] | lineID,
 |  | WatchdogExpirationState[] | expirationState )

Add multiple channels.

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | an array of line numbers of added lines.
expirationState | an array addition Expiration state.

◆ AddChannel() [4/5]

void JY5412.JY5412DOWatchdogTask.AddChannel | ( | int[] | portID,
 |  | int[] | lineID,
 |  | WatchdogExpirationState | expirationState )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | an array of line numbers of added lines.
expirationState | Expiration state.

◆ AddChannel() [5/5]

void JY5412.JY5412DOWatchdogTask.AddChannel | ( | int[] | portID,
 |  | int[] | lineID,
 |  | WatchdogExpirationState[] | expirationState )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | an array of line numbers of added lines.
expirationState | an array addition Expiration state.

◆ ClearExpiration()

void JY5412.JY5412DOWatchdogTask.ClearExpiration ( )

Clear the locked state of the timeout watchdog task.

Exceptions
JYDriverException

◆ Commit()

void JY5412.JY5412DOWatchdogTask.Commit ( )

After modifying the expiration status and timeout time during the operation, submit the configuration.

Exceptions
JYDriverException

◆ RemoveChannel() [1/2]

void JY5412.JY5412DOWatchdogTask.RemoveChannel | ( | int | portID,
 |  | int | lineID )

Delete the specified line number .If it is -1, delete all lines.

Parameters
portID | port number to be delete.
lineID | line number to be delete.

◆ RemoveChannel() [2/2]

void JY5412.JY5412DOWatchdogTask.RemoveChannel | ( | int[] | portID,
 |  | int[] | lineID )

Delete the specified line number .

Parameters
portID | port number to be delete.
lineID | line number to be delete.

◆ ResetTimer()

void JY5412.JY5412DOWatchdogTask.ResetTimer ( )

Resetting the watchdog task is equivalent to feeding the dog.

◆ Start()

void JY5412.JY5412DOWatchdogTask.Start ( )

启动看门狗任务 Run the watchdog task

◆ Stop()

void JY5412.JY5412DOWatchdogTask.Stop ( )

停止看门狗任务 Stop the watchdog task

Property Documentation

◆ Channels

List<WatchdogChannel> JY5412.JY5412DOWatchdogTask.Channels
getset

WatchdogChannel list.

◆ Device

JY5412Device JY5412.JY5412DOWatchdogTask.Device
get

JY5412Device.

◆ Expired

bool JY5412.JY5412DOWatchdogTask.Expired
get

Check to see if the watchdog has expired.

◆ Timeout

double JY5412.JY5412DOWatchdogTask.Timeout
getset

Timeout time, unit: seconds.

The documentation for this class was generated from the following file:
  • C:/C#/JY5412DOWatchdogTask.cs


5412 C# Programming Manual: Member List

  • JY5412DOWatchdogTask
JY5412.JY5412DOWatchdogTask Member List

This is the complete list of members for JY5412.JY5412DOWatchdogTask, including all inherited members.

AddChannel(int portID, int lineID, WatchdogExpirationState expirationState) | JY5412.JY5412DOWatchdogTask
AddChannel(int portID, int[] lineID, WatchdogExpirationState expirationState) | JY5412.JY5412DOWatchdogTask
AddChannel(int portID, int[] lineID, WatchdogExpirationState[] expirationState) | JY5412.JY5412DOWatchdogTask
AddChannel(int[] portID, int[] lineID, WatchdogExpirationState[] expirationState) | JY5412.JY5412DOWatchdogTask
AddChannel(int[] portID, int[] lineID, WatchdogExpirationState expirationState) | JY5412.JY5412DOWatchdogTask
Channels | JY5412.JY5412DOWatchdogTask
ClearExpiration() | JY5412.JY5412DOWatchdogTask
Commit() | JY5412.JY5412DOWatchdogTask
Device | JY5412.JY5412DOWatchdogTask
Expired | JY5412.JY5412DOWatchdogTask
JY5412DOWatchdogTask(int slotNumber=0) | JY5412.JY5412DOWatchdogTask
JY5412DOWatchdogTask(string boardName) | JY5412.JY5412DOWatchdogTask
RemoveChannel(int portID, int lineID) | JY5412.JY5412DOWatchdogTask
RemoveChannel(int[] portID, int[] lineID) | JY5412.JY5412DOWatchdogTask
ResetTimer() | JY5412.JY5412DOWatchdogTask
Start() | JY5412.JY5412DOWatchdogTask
Stop() | JY5412.JY5412DOWatchdogTask
Timeout | JY5412.JY5412DOWatchdogTask


5412 C# Programming Manual: JY5412.JY5412PowerUpStates Class Reference

  • JY5412PowerUpStates
Public Member Functions | Properties | List of all members
JY5412.JY5412PowerUpStates Class Reference

Power-on state configuration. More...

Public Member Functions

JY5412PowerUpStates ()
constructor

Properties

PowerUpStatePortParam[] | Ports [get, set]
An array used to set the default power-on state of the logic potential.
ChannelPowerUpStates[,] | Channels [get, set]
Set the array for the default power-on state of input or output.

Detailed Description

Power-on state configuration.

Constructor & Destructor Documentation

◆ JY5412PowerUpStates()

JY5412.JY5412PowerUpStates.JY5412PowerUpStates ( )

constructor

Property Documentation

◆ Channels

ChannelPowerUpStates [,] JY5412.JY5412PowerUpStates.Channels
getset

Set the array for the default power-on state of input or output.

◆ Ports

PowerUpStatePortParam [] JY5412.JY5412PowerUpStates.Ports
getset

An array used to set the default power-on state of the logic potential.

The documentation for this class was generated from the following file:
  • C:/C#/JY5412PowerUpStates.cs


5412 C# Programming Manual: Member List

  • JY5412PowerUpStates
JY5412.JY5412PowerUpStates Member List

This is the complete list of members for JY5412.JY5412PowerUpStates, including all inherited members.

Channels | JY5412.JY5412PowerUpStates
JY5412PowerUpStates() | JY5412.JY5412PowerUpStates
Ports | JY5412.JY5412PowerUpStates


5412 C# Programming Manual: JY5412.PowerUpStateInputParam Class Reference

  • PowerUpStateInputParam
Properties | List of all members
JY5412.PowerUpStateInputParam Class Referencesealed

Input PowerUpStates param. More...

Properties

DITerminal Terminal [get, set]
Terminal Configuration.

Detailed Description

Input PowerUpStates param.

Property Documentation

◆ Terminal

DITerminal JY5412.PowerUpStateInputParam.Terminal
getset

Terminal Configuration.

The documentation for this class was generated from the following file:
  • C:/C#/JY5412PowerUpStates.cs


5412 C# Programming Manual: Member List

  • PowerUpStateInputParam
JY5412.PowerUpStateInputParam Member List

This is the complete list of members for JY5412.PowerUpStateInputParam, including all inherited members.

Terminal JY5412.PowerUpStateInputParam


5412 C# Programming Manual: JY5412.PowerUpStateOutputParam Class Reference

  • PowerUpStateOutputParam
Properties | List of all members
JY5412.PowerUpStateOutputParam Class Referencesealed

Output PowerUpStates param. More...

Properties

DOTerminal | Terminal [get, set]
Terminal Configuration.
bool | Level [get, set]
Output value.

Detailed Description

Output PowerUpStates param.

Property Documentation

◆ Level

bool JY5412.PowerUpStateOutputParam.Level
getset

Output value.

◆ Terminal

DOTerminal JY5412.PowerUpStateOutputParam.Terminal
getset

Terminal Configuration.

The documentation for this class was generated from the following file:
  • C:/C#/JY5412PowerUpStates.cs


5412 C# Programming Manual: Member List

  • PowerUpStateOutputParam
JY5412.PowerUpStateOutputParam Member List

This is the complete list of members for JY5412.PowerUpStateOutputParam, including all inherited members.

Level | JY5412.PowerUpStateOutputParam
Terminal | JY5412.PowerUpStateOutputParam


5412 C# Programming Manual: JY5412.PowerUpStatePortParam Class Reference

  • PowerUpStatePortParam
Properties | List of all members
JY5412.PowerUpStatePortParam Class Referencesealed

The class used to set the default logic level of the power-on state. More...

Properties

LogicLevel Logiclevel [get, set]
LogicLevel.

Detailed Description

The class used to set the default logic level of the power-on state.

Property Documentation

◆ Logiclevel

LogicLevel JY5412.PowerUpStatePortParam.Logiclevel
getset

LogicLevel.

The documentation for this class was generated from the following file:
  • C:/C#/JY5412PowerUpStates.cs


5412 C# Programming Manual: Member List

  • PowerUpStatePortParam
JY5412.PowerUpStatePortParam Member List

This is the complete list of members for JY5412.PowerUpStatePortParam, including all inherited members.

Logiclevel JY5412.PowerUpStatePortParam


5412 C# Programming Manual: JY5412.WatchdogChannel Class Reference

  • WatchdogChannel
Properties | List of all members
JY5412.WatchdogChannel Class Referencesealed

WatchdogChannel class. More...

Properties

int | PortID [get, set]
PortID.
int | LineID [get, set]
LineID.
WatchdogExpirationState | ExpirationState [get, set]
Watchdog expiration state.

Detailed Description

WatchdogChannel class.

Property Documentation

◆ ExpirationState

WatchdogExpirationState JY5412.WatchdogChannel.ExpirationState
getset

Watchdog expiration state.

◆ LineID

int JY5412.WatchdogChannel.LineID
getset

LineID.

◆ PortID

int JY5412.WatchdogChannel.PortID
getset

PortID.

The documentation for this class was generated from the following file:
  • C:/C#/JY5412DOWatchdogTask.cs


5412 C# Programming Manual: Member List

  • WatchdogChannel
JY5412.WatchdogChannel Member List

This is the complete list of members for JY5412.WatchdogChannel, including all inherited members.

ExpirationState | JY5412.WatchdogChannel
LineID | JY5412.WatchdogChannel
PortID | JY5412.WatchdogChannel


5412 C# Programming Manual: Class Index

Class Index
C | D | J | P | W
C
ChangeDetectionChannel (JY5412)
ChangeDetectionEventChannel (JY5412)
ChannelPowerUpStates (JY5412)
D
DIChannel (JY5412)
DOChannel (JY5412)
J
JY5412DIChangeDetectionTask (JY5412)
JY5412DITask (JY5412)
JY5412DOTask (JY5412)
JY5412DOWatchdogTask (JY5412)
JY5412PowerUpStates (JY5412)
P
PowerUpStateInputParam (JY5412)
PowerUpStateOutputParam (JY5412)
PowerUpStatePortParam (JY5412)
W
WatchdogChannel (JY5412)


5412 C# Programming Manual: C:/C# Directory Reference

  • File List
C# Directory Reference

Files

         JY5412DIChangeDetectionTask.cs
JY5412DITask.cs
JY5412DOTask.cs
JY5412DOWatchdogTask.cs
JY5412PowerUpStates.cs


5412 C# Programming Manual: C: Directory Reference

  • File List
  • C:
C: Directory Reference

Directories

         C#


5412 C# Programming Manual: File List

  • File List
File List
Here is a list of all files with brief descriptions:
[detail level 123]
 C:
C#
JY5412DIChangeDetectionTask.cs
JY5412DITask.cs
JY5412DOTask.cs
JY5412DOWatchdogTask.cs
JY5412PowerUpStates.cs


5412 C# Programming Manual: Class Members

  • All
  • Functions
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • w
Here is a list of all class members with links to the classes they belong to:

- a -

  • AddChannel() : JY5412.JY5412DIChangeDetectionTask, JY5412.JY5412DITask, JY5412.JY5412DOTask, JY5412.JY5412DOWatchdogTask

- c -

  • ChangeDetected : JY5412.JY5412DIChangeDetectionTask
  • ChangeDetectionMode : JY5412.ChangeDetectionChannel
  • Channels : JY5412.JY5412DIChangeDetectionTask, JY5412.JY5412DITask, JY5412.JY5412DOTask, JY5412.JY5412DOWatchdogTask, JY5412.JY5412PowerUpStates
  • ClearExpiration() : JY5412.JY5412DOWatchdogTask
  • Commit() : JY5412.JY5412DOWatchdogTask

- d -

  • Device : JY5412.JY5412DIChangeDetectionTask, JY5412.JY5412DITask, JY5412.JY5412DOTask, JY5412.JY5412DOWatchdogTask

- e -

  • EnableDigitalFilter : JY5412.ChangeDetectionChannel, JY5412.DIChannel
  • ExpirationState : JY5412.WatchdogChannel
  • Expired : JY5412.JY5412DOWatchdogTask

- i -

  • Input : JY5412.ChannelPowerUpStates

- j -

  • JY5412DIChangeDetectionTask() : JY5412.JY5412DIChangeDetectionTask
  • JY5412DITask() : JY5412.JY5412DITask
  • JY5412DOTask() : JY5412.JY5412DOTask
  • JY5412DOWatchdogTask() : JY5412.JY5412DOWatchdogTask
  • JY5412PowerUpStates() : JY5412.JY5412PowerUpStates

- l -

  • Level : JY5412.ChangeDetectionEventChannel, JY5412.PowerUpStateOutputParam
  • LineID : JY5412.ChangeDetectionChannel, JY5412.ChangeDetectionEventChannel, JY5412.DIChannel, JY5412.DOChannel, JY5412.WatchdogChannel
  • Logiclevel : JY5412.PowerUpStatePortParam

- m -

  • Mode : JY5412.ChannelPowerUpStates

- o -

  • Output : JY5412.ChannelPowerUpStates

- p -

  • PortID : JY5412.ChangeDetectionChannel, JY5412.ChangeDetectionEventChannel, JY5412.DIChannel, JY5412.DOChannel, JY5412.WatchdogChannel
  • Ports : JY5412.JY5412PowerUpStates

- r -

  • ReadSinglePoint() : JY5412.JY5412DIChangeDetectionTask, JY5412.JY5412DITask
  • RemoveChannel() : JY5412.JY5412DIChangeDetectionTask, JY5412.JY5412DITask, JY5412.JY5412DOTask, JY5412.JY5412DOWatchdogTask
  • ResetTimer() : JY5412.JY5412DOWatchdogTask

- s -

  • Start() : JY5412.JY5412DIChangeDetectionTask, JY5412.JY5412DOWatchdogTask
  • Stop() : JY5412.JY5412DIChangeDetectionTask, JY5412.JY5412DOWatchdogTask

- t -

  • Terminal : JY5412.ChangeDetectionChannel, JY5412.DIChannel, JY5412.DOChannel, JY5412.PowerUpStateInputParam, JY5412.PowerUpStateOutputParam
  • Timeout : JY5412.JY5412DOWatchdogTask

- w -

  • WriteSinglePoint() : JY5412.JY5412DOTask


5412 C# Programming Manual: Class Members - Events

  • All
  • Functions
  • Properties
  • Events
Here is a list of all events with links to the classes they belong to:
  • ChangeDetected : JY5412.JY5412DIChangeDetectionTask


5412 C# Programming Manual: Class Members - Functions

  • All
  • Functions
  • Properties
  • Events
  • a
  • c
  • j
  • r
  • s
  • w
Here is a list of all functions with links to the classes they belong to:

- a -

  • AddChannel() : JY5412.JY5412DIChangeDetectionTask, JY5412.JY5412DITask, JY5412.JY5412DOTask, JY5412.JY5412DOWatchdogTask

- c -

  • ClearExpiration() : JY5412.JY5412DOWatchdogTask
  • Commit() : JY5412.JY5412DOWatchdogTask

- j -

  • JY5412DIChangeDetectionTask() : JY5412.JY5412DIChangeDetectionTask
  • JY5412DITask() : JY5412.JY5412DITask
  • JY5412DOTask() : JY5412.JY5412DOTask
  • JY5412DOWatchdogTask() : JY5412.JY5412DOWatchdogTask
  • JY5412PowerUpStates() : JY5412.JY5412PowerUpStates

- r -

  • ReadSinglePoint() : JY5412.JY5412DIChangeDetectionTask, JY5412.JY5412DITask
  • RemoveChannel() : JY5412.JY5412DIChangeDetectionTask, JY5412.JY5412DITask, JY5412.JY5412DOTask, JY5412.JY5412DOWatchdogTask
  • ResetTimer() : JY5412.JY5412DOWatchdogTask

- s -

  • Start() : JY5412.JY5412DIChangeDetectionTask, JY5412.JY5412DOWatchdogTask
  • Stop() : JY5412.JY5412DIChangeDetectionTask, JY5412.JY5412DOWatchdogTask

- w -

  • WriteSinglePoint() : JY5412.JY5412DOTask


5412 C# Programming Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • Events
  • c
  • d
  • e
  • i
  • l
  • m
  • o
  • p
  • t
Here is a list of all properties with links to the classes they belong to:

- c -

  • ChangeDetectionMode : JY5412.ChangeDetectionChannel
  • Channels : JY5412.JY5412DIChangeDetectionTask, JY5412.JY5412DITask, JY5412.JY5412DOTask, JY5412.JY5412DOWatchdogTask, JY5412.JY5412PowerUpStates

- d -

  • Device : JY5412.JY5412DIChangeDetectionTask, JY5412.JY5412DITask, JY5412.JY5412DOTask, JY5412.JY5412DOWatchdogTask

- e -

  • EnableDigitalFilter : JY5412.ChangeDetectionChannel, JY5412.DIChannel
  • ExpirationState : JY5412.WatchdogChannel
  • Expired : JY5412.JY5412DOWatchdogTask

- i -

  • Input : JY5412.ChannelPowerUpStates

- l -

  • Level : JY5412.ChangeDetectionEventChannel, JY5412.PowerUpStateOutputParam
  • LineID : JY5412.ChangeDetectionChannel, JY5412.ChangeDetectionEventChannel, JY5412.DIChannel, JY5412.DOChannel, JY5412.WatchdogChannel
  • Logiclevel : JY5412.PowerUpStatePortParam

- m -

  • Mode : JY5412.ChannelPowerUpStates

- o -

  • Output : JY5412.ChannelPowerUpStates

- p -

  • PortID : JY5412.ChangeDetectionChannel, JY5412.ChangeDetectionEventChannel, JY5412.DIChannel, JY5412.DOChannel, JY5412.WatchdogChannel
  • Ports : JY5412.JY5412PowerUpStates

- t -

  • Terminal : JY5412.ChangeDetectionChannel, JY5412.DIChannel, JY5412.DOChannel, JY5412.PowerUpStateInputParam, JY5412.PowerUpStateOutputParam
  • Timeout : JY5412.JY5412DOWatchdogTask


5412 C# Programming Manual: Main Page

5412 C# Programming Manual Documentation


5412 C# Programming Manual: JY5412 Namespace Reference

  • Package List
  • Package Members
Classes | Enumerations
JY5412 Namespace Reference

Classes

class | JY5412DIChangeDetectionTask
JY5412 DIChange Detection Task. More...
class | ChangeDetectionChannel
ChangeDetectionChannel class. More...
class | ChangeDetectionEventChannel
ChangeDetectionEventChannel class. More...
class | JY5412DITask
DITask class. More...
class | DIChannel
DIChannel class. More...
class | JY5412DOTask
DOTask class. More...
class | DOChannel
DOChannel class. More...
class | JY5412DOWatchdogTask
DO Watchdog Task. More...
class | WatchdogChannel
WatchdogChannel class. More...
class | JY5412PowerUpStates
Power-on state configuration. More...
class | PowerUpStatePortParam
The class used to set the default logic level of the power-on state. More...
class | ChannelPowerUpStates
A class for setting the default power-on state of input or output. More...
class | PowerUpStateInputParam
Input PowerUpStates param. More...
class | PowerUpStateOutputParam
Output PowerUpStates param. More...

Enumerations

enum | ChangeDetectionMode { RisingEdge = JY5412Import.RisingEdge , FallingEdge = JY5412Import.FallingEdge , BothEdge = JY5412Import.BothEdge }
ChangeDetectionMode. More...
enum | DITerminal { Floating = JY5412Import.Floating , PullUp = JY5412Import.PullUp , PullDown = JY5412Import.PullDown }
Input terminal. More...
enum | DOTerminal { PushPull = JY5412Import.PushPull , OpenDrain = JY5412Import.OpenDrain }
DO terminal. More...
enum | WatchdogExpirationState { High = JY5412Import.High , Low = JY5412Import.Low , Tristate = JY5412Import.Tristate , NoChange = JY5412Import.NoChange }
Watchdog expiration state. More...
enum | PowerUpStateMode { Output , Input }
Power Up State Mode. More...

Enumeration Type Documentation

◆ ChangeDetectionMode

enum JY5412.ChangeDetectionMode

ChangeDetectionMode.

Enumerator
RisingEdge | Rising edge detection.
FallingEdge | Falling edge detection.
BothEdge | Edge detection.

◆ DITerminal

enum JY5412.DITerminal

Input terminal.

Enumerator
Floating | Not enable pull-up and pull-down.
PullUp | PullUp.
PullDown | PullDown.

◆ DOTerminal

enum JY5412.DOTerminal

DO terminal.

Enumerator
PushPull | Push pull.
OpenDrain | Open drain.

◆ PowerUpStateMode

enum JY5412.PowerUpStateMode

Power Up State Mode.

Enumerator
Output | OutPut.
Input | Input.

◆ WatchdogExpirationState

enum JY5412.WatchdogExpirationState

Watchdog expiration state.

Enumerator
High | High logic.
Low | Low logic.
Tristate | High-impedance.
NoChange | No change the status.


5412 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
Here is a list of all namespace members with links to the namespace documentation for each member:
  • ChangeDetectionMode : JY5412
  • DITerminal : JY5412
  • DOTerminal : JY5412
  • PowerUpStateMode : JY5412
  • WatchdogExpirationState : JY5412


5412 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
Here is a list of all namespace enums with links to the namespace documentation for each enum:
  • ChangeDetectionMode : JY5412
  • DITerminal : JY5412
  • DOTerminal : JY5412
  • PowerUpStateMode : JY5412
  • WatchdogExpirationState : JY5412


5412 C# Programming Manual: Package List

  • Package List
  • Package Members
Package List
Here are the packages with brief descriptions (if available):
N JY5412